How to Solve WordPress Visual Editor Not Showing – Finally This Problem Solved

0
211
How to Solve WordPress Visual Editor Not Showing

The visual editor in my WordPress website has not been showing. I’ve tried disabling all plugins, resetting the htaccess file, and switching to default theme. I’ve tried all things but not successful. I quick google search revealed that there were many people having the same problem, I thought it would be the usual thing and then follow a few instructions and I hope I should have my Visual Editor back in a few minutes, but I was not successful and could not see the visual editor reappear in the new post creation section. So, how to solve WordPress visual editor not showing?

I’ve tried Chrome and Firefox (both latest versions) and even after clearing both caches and force refreshing, no luck. Also I’ve tried to upgrade my wordpress to the latest version, but it still doesn’t work. The following are some of the efforts I have made to re-display the visual editor in the addition section of my wordpress post (all of them unsuccessful)

  1. I have disabled all plugins
  2. I have replaced the theme with the default theme
  3. I have cleared the cache & cookies
  4. I also unchecked the “Disable the visual editor when writing” setting in the User Profile screen. Also have tried several times to checked the box and saved my profile and then unchecked it again. I went in and clicked the box, saved it, logged out, logged back in, unchecked the box and saved and logged out again and still no luck
  5. I have replaced and reset the htaccess file configuration
  6. I have changed the permissions of WordPress directories to 755 and the files have also changed too
  7. I also added define (‘CONCATENATE_SCRIPTS’, false); in the wordpress configuration file (wp-config.php)
  8. I also added define(‘DISALLOW_FILE_EDIT’, false); in the wordpress configuration file (wp-config.php)
  9. I have also tried to toggling the val of can_compress_scripts in the DB between 0 and 1
  10. I have also tried to toggling the val of rich_editing in the DB between 0 and 1
  11. Repaired and optimized database
  12. I have also upgraded my WordPress to the most recent version
  13. Adding a filter function recommended by someone who’s said it can be down to the UserAgent string being sent to WordPress by CloudFront- just in case. I haven’t got CloudFront nor CloudFlare installed.
  14. I have also tried to install the following plugins (apparently they were fixing this problem for others ), combinations of them, then deleting them all:
    1st CloudFlare Flexible SSL
    2nd SSL Insecure Content Fixer
    TinyMCE Advanced
    Really Simple SSL
    Classic Editor

So, how I can solve my wordpress problem?. how to solve wordpress visual editor not showing?. Huh, it’s quite tiring, tense and even made me annoyed.

Finally I tried to see the error message that occurred with enabling WordPress debugging by adding define( 'WP_DEBUG', true ); in wp-config and I see an error message: [Duplicate entry '0' for key 'PRIMARY']
INSERT INTO xxxxxx_posts (post_author, post_date, post_date_gmt, post_content, post_content_filtered, post_title, post_excerpt, post_status, post_type, comment_status, ping_status, post_password, post_name, to_ping, pinged, post_modified, post_modified_gmt, post_parent, menu_order, post_mime_type, guid) VALUES (1, '2020-04-28 10:16:03', '0000-00-00 00:00:00', '', '', 'Konsep Otomatis', '', 'auto-draft', 'post', 'open', 'open', '', '', '', '', '2020-04-28 10:16:03', '0000-00-00 00:00:00', 0, 0, '', '')

This error caused not able to create new post(s), new page(s), all post/page have the publish button replaced with submit for review and no visual editor (visual editor not visible). No permalink, just “?preview=true”. So….how to solve wordPress Visual Editor not showing?. How to solve [Duplicate entry '0' for key 'PRIMARY']?

Finally…..here is the solution for my wordPress Visual Editor not showing. I run the following SQL command on my wordpress post table
DELETE FROM xxxxxxx_posts WHERE ID = 0
ALTER TABLE xxxxxx_posts MODIFY ID bigint (20) unsigned NOT NULL auto_increment

So the visual composer has now reappeared. Hurray….finally my wordpress problem Visual Editor not showing solved!